Cannot copy necessary linked file(s)? – Error Message

Home Forums General InDesign Topics Cannot copy necessary linked file(s)? – Error Message

This topic contains 26 replies, has 19 voices, and was last updated by  D Sam 1 month, 2 weeks ago.

  • Author
    Posts
  • #61350

    Billy Chase
    Member

    I get this message when I try to package up some documents. I've checked my links and nothing seems to be broken. I seem to only get this on a batch of documents and not on any others. I thought it might be a problem when I upgraded to Lion but that doesn't seem to be the case as other files will package fine.

    What would cause this and how can one fix it?

  • #61481

    Billy Chase
    Member

    Nothing?

    It's really odd that this is happening. I can't figure out how to get the file to package properly. Other InDesign files new and old package fine.

    Thanks,

    Billy

  • #61484

    Eugene Tyson
    Member

    The message really doesn't tell us anything.

    Are all the links up to date in the Links panel – no warning symbols?

  • #61487

    Eugene Tyson
    Member

    Check your Layers Panel

    And expand each layer – ensure there are no “Hidden Layers” that is the “eye” icon is showing beside each layer

  • #61489

    I had the same problem just now. I looked for Hidden Layers as suggested above and also tried replacing the preferences as outlined in the Adobe Forums about this issue, but had no luck. However, I did find a solution that seemed to work … as long as you still have a previous version of ID on your system: I “saved down” the file (from CS5.5, exported as an .idml file) then opened the .idml file in CS4 and was able to successfully package the file from there. Hope this helps.

  • #61490

    Eugene Tyson
    Member

    That is not a recommended workflow. Any new features used in CS5.5 or CS5 will be lost downsaving to CS4, as CS4 did not have those features. You risk messing up the entire document text layout.

  • #61780

    Billy Chase
    Member

    I think I finally figured it out. The links were not missing and there weren't any warning signs. What happened was a file was labeled in correctly. It contained slashes in the title. Once I renamed the file, everything packaged up fine.

    Thanks to everyone for trying to help.

  • #67465

    Kait Hatch
    Member

    I’m using InDesign CC and have just had the same error message.

    I’ve done some digging around.
    1 – None of the links in my links panel are broken.
    2 – None of the file names have a / in them, which was sited as the most common reason this would happen.
    3 – I tried resaving all the links to a new location and was met with another error message that links could not be moved.
    4 – I renamed two of my images as they had extremely long names and this was also sited as a reason for this error.

    I still can’t package it and the error message is frustrating since it doesn’t explain why and preflight shows no issues with the document.

  • #67607

    I have recently upgraded to Maverick and now I can’t package any files. I am currently using CS6. I have tried repackaging a file that I could before the upgrade and I get the error message as stated above. This is very frustrating since I can’t do my job and have to rely on others who are able to package the files.

    I even resaved the file as an idml and reopened in CS5.5 and I get the same error. Any help would be greatly appreciated.

    • #67614

      Kait Hatch
      Member

      Hi Leisa,
      in the end, despite posting on the Adobe help forums as well as here, I had to use a rather clunky solution. I resaved all the image files in a new folder and relinked them to the document. It packaged fine after that but was quite tedious to do.

      I have Marverick on my home computer for all my freelancing work and haven’t had any issues with packaging from there. This happened to me on the PC at my work – so I don’t think the operating system has anything to do with it.

  • #67645

    Masood Ahmad
    Member

    I have a suggestion not to use long file-names instead use a small, easy to read names. Also try not to use any special characters i.e. ~!@#$%^&*()-=+[{]}\|;:'”/?.>,< as these symbols reserve some place in the Operating Systems’ coding.

    You will get numerous error messages on PC if any of these character is used somewhere in the file-name, whereas on MAC, these are ignored sometimes by the MAC OS. One might not get any error on a MAC but might get errors on PC with the same file.

    Rather than copying or pasting or downloading the stuff from the net and using it straight away, try to rename the file if the name is too long or contains special characters.

    Remember the Golden days of DOS where 8.3 was a file-naming standard :)

    • #67647

      Kait Hatch
      Member

      Masood,
      In my post on March 6th I state that I renamed long file names and don’t have unusual characters in any of my file names.

      This didn’t resolve the issue.

      Kait

  • #67646

    Files that I was able to package before we upgraded tot he new OS, I can no longer package. None of our files have any special characters in them and we try to keep them short as possible. We are so confused as to why after upgrading tot he new OS (Maverick) I can’t package any longer.

    • #67648

      Kait Hatch
      Member

      Mine was the same but on a PC with Windows 7. I used to be able to package the file I got the error message with. I suspected ti was a result up switching from CS6 to CC, but if you’ve had the same issue it can’t be that.

      Have you flagged it with Adobe?

  • #68199

    Karen Booth
    Member

    Hey, all,

    I have just experienced this problem in CS5.5 while attempting to package an 80-page book with 300+ linked files. The problem turned out to be several linked jpeg files that had the slash character (“/”) in the file names. Once I changed all those offending file names and re-linked all those files in the ID document, the packaging function worked perfectly. Hope this helps others experiencing this problem!

  • #68728

    I just started getting this message. I’ve been working in CC for quite a while now, well since its unveiling, and never got the message until now. The original file might have been created in CS6 but I’ve done this with earlier versions and while I did have to relink I never got this message. I’m also connecting to a remote server using VPN which I thought might be the case. Anyways, no errors in preflight, tried relinking files, embedding them…no luck. There are only 6 links, not a lot to handle, and no special characters in file names…I’m going to try Kait Hatch’s idea and save all the files to a common subfolder under my work folder and see if relinking them to there works.

  • #70737

    Jim Cochrane
    Member

    I only had 16 links so I could have checked each one … I had an illustrator, ai file which I saved as an illustrator pdf and replaced … and then it worked … if that helps anyone …

  • #70738

    Justin Sligh
    Member

    You will get that error if your document links to media on an older drive or another user, which you do not have proper permissions for.

  • #70768

    Mark Chen
    Member

    ok, ran into the same problem, I think I found a solution.

    first, embed all your links. then unembed all the links, NOT to the original location, but to a new location. so create a new folder for all the linked files. after you have copied all the files into that folder, you can check for any files that have “/” in their names.

    I did this and sure enough, found this one file with “/” in its name. I didn’t bother to try to package again with the same file name just to see if the reason for the problem is indeed the “/”. I just changed the file name and the package was done without any problem.

  • #70783

    Tim Hughes
    Member

    I’ve this problem and it was down to a bad file name.

  • #70987

    I ran into to problem too. I had all my images in a folder name “IMAGES” and once I changed the folder name from “IMAGES” to “Links” I was able to package it.

  • #76295

    Wow thanks for this info I had 339 links & 2 had “/” in them, removed them and it fixed the problem.

  • #76387

    Tayler Ursu
    Member

    The Fix: / at the start of file names need to be removed. No need to do anything else.

    1) Find the original file – rename it without a slash
    2) Proceed to relink the file in indesign.

    FIXED!

  • #76741

    Lauren Kirk
    Member

    Worked for me I had 562 links, removed all image files with a “/” and saved perfectly :-)

  • #76759

    Andre Vandal
    Member

    I don’t think this is limited to slashes, here we work in French and we had the same problem with accents in filenames, i.e.: é è à ô etc.
    We seem to be regressing back to DOS. :)

  • #97900

    Eric Chapman
    Member

    I just had the same problem in InDesign CS6. Although when trying to package it, ID said all 13 linked files were problems, only one had “/” in it. It exports to a package just fine now that the “/” is replaced with a “-“. Thanks to all who contributed to this thread!

  • #103543

    D Sam
    Member

    I had exactly the same problem and changed an “/”.
    It’s a pity, it’s like we are back in DOS again :(

You must be logged in to reply to this topic.