Table border: only outside rules (no interior rules)?

Home Forums General InDesign Topics Table border: only outside rules (no interior rules)?

This topic contains 4 replies, has 2 voices, and was last updated by  Steve Straus 2 months, 2 weeks ago.

  • Author
    Posts
  • #125818

    Steve Straus
    Member

    Table borders have always been a bit of an oddball feature as they simply aren’t as logical as would like them to be. Is there a way to make a simple table style (2 columns, 4 rows) that only has borders on the outside and not on any interior verticals or horizontals? I need to automate this using table styles for a book so manual tweaking is what I am hoping to avoid. I have tried Table Borders but these are linked to the cell style rules. While this is a simple 2-column table that I need, I have figured out how to use the left/right cells to avoid the extra vertical rules, but short of making the top a header and bottom a footer (manual tweaks), I can’t figure out how to get a table to consistently work automatically.

    Here is a sample of a test doc that I can’t get to work: https://www.dropbox.com/s/9iau2kfo890zjb7/table-sample.indd?dl=1

    Any suggestions? Thanks!

  • #125819

    Hi Steve, take a look at ‘Row Strokes’ and ‘Column Strokes’ in the Table Style options window. Choose ‘Every other row/column’ and put the color to ‘None’. Manual tweaking avoided! If you wan’t to share the profit, always welcome ;-)

  • #125822

    Steve Straus
    Member

    You have earned your ID Master badge for the day! This works perfectly. Do you want to go double or nothing with table issues? Another ongoing issue I have with tables in in the column heads. For a multiple column head with a column rule between each column, how do I automatically turn off the outside columns so the disappear? The left side drops off but the right side always picks up the style of the middle divider, thus I need to manually turn this border off.

    Here’s a sample of what my problem is (tweaked for easy reading):

    https://www.dropbox.com/s/xzienor4bs9h2aq/Table2.indd?dl=1

  • #125826

    Hi Steve, don’t be lazy, I gave you the solution already. This is just a workaround.

  • #125827

    Steve Straus
    Member

    Marc — sorry to mislead you. Your solution worked perfectly and for that I am grateful. Since you seem to have an amazing grasp on some of the intimate details of charts, I was merely hoping to tap into this expertise one more time. My response was another issue that I can’t seem to figure out.

You must be logged in to reply to this topic.